USB 3.0または2.0カメラで「フレームドロップ」が発生した場合の解決方法
USB 3.0 / 2.0カメラで「フレームドロップ」が発生した場合の解決方法
このサポート記事では、USB 3.0および2.0カメラで発生する「フレームドロップ」の診断と解決方法について説明します。
症状
カメラのライブプレビューが「カクカク」して見える
キャプチャした動画クリップに重複したフレームが多数含まれている
カメラの「詳細設定」ウィンドウに多数のフレームドロップが表示されている
原因
フレームドロップの問題はいくつかの要因に関連している可能性がありますが、根本的な原因はUSBカメラがUSBバスの利用可能な帯域幅に制限されることにあります。USB 3.0はUSB 2.0よりもはるかに高い帯域幅を持っているため、USB 3.0搭載のノートパソコンでは複数のカメラを使用することが可能ですが、制限事項はほぼ同様です。
他のUSBデバイスが接続されている場合、それらが帯域幅を「占有」してしまう可能性があります。
コンピューターが省電力のために「アイドル」状態に入ろうとすると、USB 3.0または2.0のパフォーマンスに影響を与え、フレームドロップが発生する場合があります。
複数のGPU(IntelとNVIDIAの組み合わせなど)を搭載したノートパソコンをお使いの場合、Swing Catalystに最も高パフォーマンスなGPUが使用されるよう設定することが重要です:https://pureinfotech.com/set-gpu-app-windows-10/
解決方法
カメラの「詳細設定」で「ピクセルクロック」を下げてください。これで改善されるものの、フレームレートが大幅に低下する場合は、以下の他の解決策をお試しください。
ウェブカメラなど、他の(アクティブな)USBデバイスが接続されていないことを確認してください。
「CPU アイドル状態を無効にする」設定を有効にしてください。この設定は、アプリケーション「IDS Camera manager」の「Additional Functions」ボタン/ダイアログから確認できます。他のカメラメーカーにも同様の機能があります。
Windowsの「電源プラン」を変更してください。詳しくはこちらの記事をご覧ください:../account-setup/optimize-laptop.md
最終更新日: 2021-06-16 | 公式サポートサイトで見る